Jump to content

Lupo 1.8T loading...


lllllupo
 Share

Recommended Posts

Hey everyone 👋

I picked up a dirt cheap Lupo a while a go and it's been good to knock about in and that. The only problem is, it's a 1.0 and the severe lack of speed is quite frustrating. I've not had anything particularly quick on 4 wheels but have had a motorcycle since I was 17.

One night, after a few beers I bid on a Mk4 Golf GTI thinking nothing of it... until I woke up the next day and won it!! 

Oops.

It was cheap, has some problems, but it was cheap. It's a 150bhp AUM with a 5spd box and full leather interior. It drives OK enough and for the most part works, although there is an issue at idle which needs addressing. It vibrates quite a bit at idle but smooths out as the revs rise - I'll be checking the spark plugs & doing a compression test to see whats up.

And thats the start of my Lupo 1.8T build...

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.