Jump to content
Sign in to follow this  
Uggi

Another Noob!

Recommended Posts

Hi folks!, just joined the forum, I live in Orkney and bought a Lupo sdi a few weeks ago as a project since the timing belt had snapped with the previous owner, its back in use, but there has been a lot of niggly wee problems, but they are getting less now too! lol

I gleaned a lot of tips from this site for a lot of the problems, and thought I would join so I can add my tuppence worth if I can help.

Cheers

Andy

Share this post


Link to post
Share on other sites

Welcome!

What's on the to do list for the SDI?

Share this post


Link to post
Share on other sites

Hi, I have been out working on it last night, so there is not a lot left to do now. Story so far is,

I bought the car for £100 as it had been towed to a garage with a snapped timing belt. So I took the head off and apart to see what it was needing. so to get it going again it needed;

8 Tappets - as they were all "domed" (got these and the guides out of an old Inca 1.9sdi van)

3 New valves - bent quite bad

3 Valve guides - scored quite badly taking out the bent valves

8 New valve stem oil seals

Cam oil seal

Head gasket set

Timing belt kit - full kit

Water pump - Just to be on the save side

EGR Blanking plate - what a mess was in the inlet side

Removed the inlet air restrictors and gave the ports good clean and a light polish

New oil, oil filter, fuel filter and air filter.

That got it running, but sadly the spending had to continue lol, so I bought the following;

Front discs and pads

Rear drums, shoes and cylinders - still waiting on drums £22 a PAIR on ebay, was quoted £65+vat EACH at local factors!

Track rod ends

Remote locking kit - doddle to fit with this site's how to section(i wired the indicators wire to the hazard switch)

Various bulbs - interior, dash, headlight, high level brake light needed new connections made!

Last night I did;

4 new glow plugs - as it was a bit "white smokey" on a cold start up. I got denzo fast heat up ones off ebay £6 odd each.

New temp sensor - What a difference as it used to rev itself when I was starting it (hot or cold) and the glow plug light light was staying on for ages. cheap fix

Heater resistor - no more only fan speed 4!

So the to-do list only has;

Gearbox oil seal - at least!

fit the back brakes when the drums arrive(from France!)

tidy up the body work - after incident involving pressure washer and bonnet's laquer DOH!

do something with the ultra soft suspension, don't want to go much lower, just stiffer

probably alloys at some point, but must fit the winter wheels tonight as we have snow forecast for the start of the week!

Thats the story so far, I bet you are sorry you asked!! lol

  • Like 1

Share this post


Link to post
Share on other sites

hi

have a lupo thats indicators have packed up. \the hazards work so i know the bulbs work as do alll the fuses. Now the wipers are not working.

Can anyone help

Grovey

Share this post


Link to post
Share on other sites

Think you should just go to a sparky grovey, would be a bit unsafe to use the car without them and the problem sounds to be getting worse

Also Uggi your hardly a noob lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.