Jump to content

Possible solution to sticking electric windows?


Recommended Posts

Hi All, just picked up my first Arosa and I love it! It came with a driver side window that wouldn't move at all, having previously been sticking halfway.

My father and I tried a bunch of things I've seen suggested on various forums, including here, greased the runners, oiled the cables, greased the worm gear, etc, nothing presented a permanent solution, the window would work ok, but once it met any resistance it would just refuse to go any further. Switchgear was ok. After a while we had it so that it would move, but only up or down one step at a time, and you had to taker your finger off the button and press it again to get it to move another half an inch. Then it just stopped again and the relay would just click, as before, no movement. Having fished the glass out of the door and taken the mechanism back off, we tried something new.

Turns out the problem was in the motor. The contacts were A-OK but there was a bunch of carbon dust in and around there and, importantly, the plastic/brass ring that the motor speed sensors pick up on.

Pulled the shaft including the windings out of the gearbox and pulley housing, removed the motor casing, and blasted everything out with an air line. Greased the shaft ends up, put it back together and it works perfectly! I guess the dust was causing shorts or making the electronics think the window had jammed or something, thus preventing movement for safety.

Anyway, just thought I'd share in case anyone has had a similar problem but not been able to fix theirs, I don't think I've seen this solution posted anywhere. Apologies if it was common knowledge.

Love my new '01 Arosa S 1.0, love the forums!

Thanks, Tango

  • Like 1
Link to post
Share on other sites
  • 4 months later...

Thanks for posting this, just trolling about here as my drivers side window has got the hump and doesn't work, replaced the switch and can hear the relay clicking but the window just sits there looking smug and refusing to move. I can see some window regulator cleaning coming up this weekend. :-)

Link to post
Share on other sites
  • 1 month later...

think this has answered my problem too. window doesnt even attempt to move but when i press the switch it makes a clicking noise down by the motor. i checked the swtich on the passenger window and its clean and works. hopefully cleaning the motor will get it working again

Link to post
Share on other sites
  • 6 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.