Jump to content
Sign in to follow this  
John E

Pedal box help!!!

Recommended Posts

Hi there,

Just bought a 2003 1.0s model, as a bit of a doer upper, loads of fun!

Problem I have is the notorious (as it turns out) pedal box broken. It’s been bodged up previously and the broken bracket is missing.

I have bought a new one from TPS, and looks quite different to the original (modified I assume), followed the thread here for removal, but on swappping over the pedal, etc I can’t see anywhere that the clutch cable mounts to, Just seems from the grommet in the bulkhead there’s nothing until the pedal, and it looks like it needs some sort of support for the clutch cable to mount on. 

Please can someone help me or tell me what I need to get

many thanks in advance

Share this post


Link to post
Share on other sites

Just been on the phone to TPS and it appears that I have the wrong part, hopefully right one will appear on Tuesday. Although it’s now cost me another £40 for a brake pedal and bushes etc

Share this post


Link to post
Share on other sites

location?

Share this post


Link to post
Share on other sites

Hiya

Im in Manchester, hopefully Tuesday I’ll have the correct pedalbox, then back on my back to get it all refitted. But I’m sure I’ll be back asking for a bit more advice, I know it has an EML light on, something to do with the EGR valve, then a full service inc cam belt/ water pump as well. Then I can get it on the road for a bit of fun! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×