Jump to content

Recommended Posts

Hi guys

I'm a complete audio novice so go easy please. I want to upgrade my sound system in my Lupo 1.0. 

I'm looking at replacing the front speakers for Rainbow DL-X6s. I'm aware I need to get the adapter ring for them to fit. http://www.caraudiodirect.co.uk/rainbow-dl-x6-6-5-coaxial-speakers

I'm wanting to put the following sub in the boot- Hertz Energy ES 250D.5. http://www.caraudiodirect.co.uk/hertz-energy-es250d-5

Does anybody have any experience with these? Would you recommend them? If not is there something better out there for similar money?

And will this amp be powerful enough to run them? It states it can be ran as a 3 channel system. Hertz HCP 4D http://www.caraudiodirect.co.uk/hertz-hcp-4d

Thanks in advance for in input and advice

 

 

Share this post


Link to post
Share on other sites

what radio have you got, amps are generally driven by RCA input (red and white plug), if your radio has these on the back then thats good news, if not you will need somthing like a PC1-601 Line Output Connector from halford that converts speak output form your radio to the required rca standards

you need to think about where you are placing your amp. it will need a direct feed from your battery, with the fuse as close to the battery as possible, getting this feed to the amp is about 80% of the job

Share this post


Link to post
Share on other sites

I wouldn't bother replacing the OEM speakers unless you're getting good quality component stuff.

Share this post


Link to post
Share on other sites
2 hours ago, Mobieus_uk said:

what radio have you got, amps are generally driven by RCA input (red and white plug), if your radio has these on the back then thats good news, if not you will need somthing like a PC1-601 Line Output Connector from halford that converts speak output form your radio to the required rca standards

you need to think about where you are placing your amp. it will need a direct feed from your battery, with the fuse as close to the battery as possible, getting this feed to the amp is about 80% of the job

Thanks for the info. I was hoping to run my amp from the boot. That sounds like some work then!

I have a pioneer AVH-280BT https://www.caraudiocentre.co.uk/product_m-pioneer-avh-280bt_p-33042.htm

 

Share this post


Link to post
Share on other sites
1 hour ago, Skezza said:

I wouldn't bother replacing the OEM speakers unless you're getting good quality component stuff.

You reckon adding the sub will be enough then? Thanks 

Share this post


Link to post
Share on other sites

Yep.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.