Jump to content

Recommended Posts

isn't the problem ignition on and it just cranks away?

something fishy going on at the starter?

  • Like 1

Share this post


Link to post
Share on other sites

Right mate this is what happens.. 

I put key in ignition and turn ignition on. All lights on dash come on as they should. I turn the key to start the car and starter motor does as it should (engine does not start) I realise the key but the starter motor is still turning the engine over and won't stop turning it over until I turn the ignition off.

Hope this is more understanding for you buddy 

 

 

 

Share this post


Link to post
Share on other sites

Just re-read this old thread... It might be relay wiring.

A relay engages then stays engaged. Power to one of the relay terminals (coil) is receiving power through its own switched contacts. So if you supply power to the relay, it will engage, but then when you release it, power is now being supplied from an alternative source- probably from one of the switch terminals. So it can never disengage until all the power feed has been cut. Try swapping the switch contact spade terminals over. Leave the coil terminals alone though.

Share this post


Link to post
Share on other sites

the starter isn't linked to relay 22.

Share this post


Link to post
Share on other sites
6 hours ago, mk2 said:

Just re-read this old thread... It might be relay wiring.

A relay engages then stays engaged. Power to one of the relay terminals (coil) is receiving power through its own switched contacts. So if you supply power to the relay, it will engage, but then when you release it, power is now being supplied from an alternative source- probably from one of the switch terminals. So it can never disengage until all the power feed has been cut. Try swapping the switch contact spade terminals over. Leave the coil terminals alone though.

classic memory circuit, that what we used to call them when a output from a relay was wired back to its own energising coil, normally by mistake

Share this post


Link to post
Share on other sites
5 hours ago, Rich said:

the starter isn't linked to relay 22.

he's modded everything though... ?

@mobius- yeah classic memory circuit!!! I'm glad someone's paying attention! :)

Share this post


Link to post
Share on other sites

he hasn't nodded, just transplanted.

Share this post


Link to post
Share on other sites

Hmmm. Then everything should work. 

Odd.

Share this post


Link to post
Share on other sites

who knows what happens when people play with things....

Share this post


Link to post
Share on other sites

It's the crank shaft sensor that's why it's not working and must be a faulty ignition switch.. when I wiggle the key the starter motor stops when ignition is on and works as it should :)

But that's for all your guys help 

 

Share this post


Link to post
Share on other sites

See, sort the constant crank then deal with the not starting. :)

all comes in sequence.

what's next?

Share this post


Link to post
Share on other sites
18 hours ago, Kurtisvdubber said:

It's the crank shaft sensor that's why it's not working and must be a faulty ignition switch.. when I wiggle the key the starter motor stops when ignition is on and works as it should :)

But that's for all your guys help 

 

deleted comment as was thinking about a cam sensor

Edited by Mobieus_uk

Share this post


Link to post
Share on other sites
10 hours ago, Rich said:

See, sort the constant crank then deal with the not starting. :)

all comes in sequence.

what's next?

Agreed. Next!?!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×